• Announcements

    • PsychoI3oy

      Unsupported devices & future versions   09/03/16

      Unsupported devices posts outside the Device requests forum will be deleted without comment. Posts asking about/for future versions of CM will be locked and/or deleted.   We don't have a crystal ball; we don't know if someone will make CM $version for your deivce or if CM $version+1 will be made for your supported device.

Terminal Emulator Not Working Anymore

6 posts in this topic

I'm running the nightly cm-10.1-20130109-NIGHTLY-i9300 and wanted to start Terminal emulator yesterday and it just crashed. I've used it before but that was quite a while ago, I don't know when this problem started occurring as I have been updating to new nightlies quite frequently using the CyanogenMod update feature.

I'm using gapps 121212 and have tried to restart the phone but I did not wipe.

Does anyone have a solution or know what is causing this? It's nice not having to use ADB if I just want to check something quickly.

Below is a piece of logcat. If you need more, let me know.

I/dalvikvm( 3110): Jit: resizing JitTable from 8192 to 16384

D/dalvikvm( 3060): GC_CONCURRENT freed 393K, 21% free 2912K/3644K, paused 17ms+2ms, total 50ms

I/ActivityManager( 2381): START u0 {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=jackpal.androidterm/.Term} from pid 3110

I/ActivityManager( 2381): Start proc jackpal.androidterm for activity jackpal.androidterm/.Term: pid=27965 uid=10043 gids={50043, 3003, 1015, 1028}

I/dalvikvm(27965): Turning on JNI app bug workarounds for target SDK version 11...

D/dalvikvm( 2381): GC_EXPLICIT freed 2310K, 38% free 17077K/27168K, paused 9ms+8ms, total 84ms

E/Trace (27965): error opening trace file: No such file or directory (2)

E/Term (27965): onCreate

D/dalvikvm(27965): GC_CONCURRENT freed 114K, 12% free 2678K/3024K, paused 2ms+1ms, total 26ms

D/Term (27965): TermService started

I/TermService(27965): Activity called onBind()

I/Term (27965): Bound to TermService

I/TermService(27965): Activity binding to service

W/dalvikvm(27965): Exception Ljava/lang/UnsatisfiedLinkError; thrown while initializing Ljackpal/androidterm/Exec;

D/AndroidRuntime(27965): Shutting down VM

W/dalvikvm(27965): threadid=1: thread exiting with uncaught exception (group=0x41067930)

E/AndroidRuntime(27965): FATAL EXCEPTION: main

E/AndroidRuntime(27965): java.lang.UnsatisfiedLinkError: Couldn't load jackpal-androidterm4 from loader dalvik.system.PathClassLoader[dexPath=/system/app/Term.apk,libraryPath=/data/app-lib/jackpal.androidterm-1]: findLibrary returned null

E/AndroidRuntime(27965): at java.lang.Runtime.loadLibrary(Runtime.java:365)

E/AndroidRuntime(27965): at java.lang.System.loadLibrary(System.java:535)

E/AndroidRuntime(27965): at jackpal.androidterm.Exec.<clinit>(Exec.java:33)

E/AndroidRuntime(27965): at jackpal.androidterm.ShellTermSession.createSubprocess(ShellTermSession.java:198)

E/AndroidRuntime(27965): at jackpal.androidterm.ShellTermSession.initializeSession(ShellTermSession.java:135)

E/AndroidRuntime(27965): at jackpal.androidterm.ShellTermSession.<init>(ShellTermSession.java:88)

E/AndroidRuntime(27965): at jackpal.androidterm.Term.createTermSession(Term.java:430)

E/AndroidRuntime(27965): at jackpal.androidterm.Term.createTermSession(Term.java:439)

E/AndroidRuntime(27965): at jackpal.androidterm.Term.populateViewFlipper(Term.java:352)

E/AndroidRuntime(27965): at jackpal.androidterm.Term.access$400(Term.java:78)

E/AndroidRuntime(27965): at jackpal.androidterm.Term$2.onServiceConnected(Term.java:148)

E/AndroidRuntime(27965): at android.app.LoadedApk$ServiceDispatcher.doConnected(LoadedApk.java:1101)

E/AndroidRuntime(27965): at android.app.LoadedApk$ServiceDispatcher$RunConnection.run(LoadedApk.java:1118)

E/AndroidRuntime(27965): at android.os.Handler.handleCallback(Handler.java:725)

E/AndroidRuntime(27965): at android.os.Handler.dispatchMessage(Handler.java:92)

E/AndroidRuntime(27965): at android.os.Looper.loop(Looper.java:137)

E/AndroidRuntime(27965): at android.app.ActivityThread.main(ActivityThread.java:5191)

E/AndroidRuntime(27965): at java.lang.reflect.Method.invokeNative(Native Method)

E/AndroidRuntime(27965): at java.lang.reflect.Method.invoke(Method.java:511)

E/AndroidRuntime(27965): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:795)

E/AndroidRuntime(27965): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:562)

E/AndroidRuntime(27965): at dalvik.system.NativeStart.main(Native Method)

W/ActivityManager( 2381): Force finishing activity jackpal.androidterm/.Term

D/dalvikvm( 2879): GC_CONCURRENT freed 4269K, 44% free 13201K/23396K, paused 6ms+3ms, total 81ms

D/dalvikvm( 2879): WAIT_FOR_CONCURRENT_GC blocked 59ms

W/ActivityManager( 2381): Activity pause timeout for ActivityRecord{41b4ff28 u0 jackpal.androidterm/.Term}

I/Process (27965): Sending signal. PID: 27965 SIG: 9

I/ActivityManager( 2381): Process jackpal.androidterm (pid 27965) has died.

I/WindowState( 2381): WIN DEATH: Window{412e00e0 u0 jackpal.androidterm/jackpal.androidterm.Term}

W/ActivityManager( 2381): Scheduling restart of crashed service jackpal.androidterm/.TermService in 5000ms

W/InputMethodManagerService( 2381): Window already focused, ignoring focus gain of: [email protected] attribute=null, token = [email protected]

I/ActivityManager( 2381): Start proc jackpal.androidterm for service jackpal.androidterm/.TermService: pid=28632 uid=10043 gids={50043, 3003, 1015, 1028}

I/dalvikvm(28632): Turning on JNI app bug workarounds for target SDK version 11...

E/Trace (28632): error opening trace file: No such file or directory (2)

D/Term (28632): TermService started

W/ProcessStats( 2381): Skipping unknown process pid 28792

Share this post

Link to post
Share on other sites

Same problem here, if i start terminal a popup occurs "terminal has been quit". I'm new to android at all, I have my s3 since about one week. Startet with build 20130105 and updated daily till 20130109. Terminal didn't work in any of these builds

Share this post

Link to post
Share on other sites

I think I read somewhere that if you delete term.apk and go to the play store and install from there it will work. I haven't tried it myself.

Share this post

Link to post
Share on other sites

As said, I'm new to android. Where is term.apk stored?

edit: got it /system/app

Works now. I opened the built-in explorer (with root perms) searched for term.apk and clicked on it. it asked for updating, I confirmed update and now it works. Great!

Edited by slashwalker

Share this post

Link to post
Share on other sites

I inactivated it in app settings and then went to Play store where I activated it again. It started working, but I had also installed nightly 20130110 without trying to start Terminal Emulator before inactivating/activating it. So I don't know exactly what fixed it. A friend who has a Nexus 4 also had the Terminal Emulator crash when running 20130109 but not with 20130110, and he did not inactivate/activate it.

Just glad it work. Thanks for the help.

Share this post

Link to post
Share on other sites

I can confirm this was fixed in yesterday's nightly (CM 10.1 BUILD 2013-01-10)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now