jgoodleaf

Sms Problem With Galaxy S3 (At&t, I747)

6 posts in this topic

Hello,

I recently installed CM 10 (10.0.0datt) on my Galaxy S3 (AT&T). Everything seems to work beautifully--and it's much better than the stock Samsung ROM--except that I can neither send nor receive SMS messages.

I did try to follow the instructions from the Wiki page (http://wiki.cyanogenmod.org/wiki/SMSC_Updates) and my SMSC setting shows "+13123149810",145. I get update errors with the PDU number, or with the unquoted number. The system seems to add the "145" part by itself. I'm not certain why, or where it comes from, which is to say I enter the SMSC number with quotes, and on refresh I get the ,145 tag added.

The phone appears to send SMS messages. That is, I get a "sending" notification and it appears good, but the SMS goes nowhere, and the phone does not receive SMS messages either.

I'm not certain what else to try. Any ideas?

Thanks,

J

Share this post


Link to post
Share on other sites

Ever thought of changing Ril and BB? Use GetRill to do so...

Share this post


Link to post
Share on other sites

I do not understand what Ril and BB means, but I'll look into GetRill. Thanks,

J

Share this post


Link to post
Share on other sites

GetRIL considers the i747 (AT&T Galaxy S3) unsupported. It works with the international version (i9300), but not for mine. No go apparently.

Share this post


Link to post
Share on other sites

jgooleaf, What build of CM10 are you running? I run the M2 snapshot and can verify that I have no problems with text or SMS messaging. I would suggest to you to download and run the M2. It seems to be the most stable build of CM10 for the i747 (AT&T Samsung Galaxy S3). I tried nightlies, but had other problems. Mostly with tinny sounding audio (a lot of people reported this). So, I went back to the M2 and everything works with the exception of the DSP Manager (audio app that lets you tweak audio like an EQ). I have heard if you reinstall the .apk for DSP Manager you can get that working as well, but I really dont use that anyway.

You can find the M2 snapshot build here: http://get.cm/?device=d2att&type=snapshot

Download the cm-10-20121011-EXPERIMENTAL-d2att-M2.zip version.

The 'M' builds are supposed to be a more stable build as I understand it. The 'M' moniker is for "milestone' builds, so they are usually pretty solid. I ran the M1 before and it ran very well compared to nightlies also. Some on the forums believe that the 'M' is supposed to be for "Monthly" and for the M1 and M2 they were released a month apart, however if that is the case the M3 is past due now, so I dont think that is the case.

Do a backup, install this version, then restore your apps and you should be good to go.

Hope that helps...Good Luck jgoodleaf

Share this post


Link to post
Share on other sites

Also what application are you using for sms/mms? If you are using something like Chomp or otherwise you need to set in the default messaging app for it to recover mms automatically and deselect that in Chomp. If you are using any other third party mms app then you may need to look into their settings.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now