• Announcements

    • PsychoI3oy

      Unsupported devices & future versions   09/03/16

      Unsupported devices posts outside the Device requests forum will be deleted without comment. Posts asking about/for future versions of CM will be locked and/or deleted.   We don't have a crystal ball; we don't know if someone will make CM $version for your deivce or if CM $version+1 will be made for your supported device.


This topic is now archived and is closed to further replies.


How Do You Disable/remove Text-To-Speech?

1 post in this topic

It keeps turning on randomly and won't stop until if feels like it or I force close the app it's reading from.

Under the Language & input > Text-to-speech output, there is only "Google Text-to-speech" and "Pico TTS". Neither has an option to turn off/uncheck or to uninstall. Any ideas how to stop the infuriating option?

EDIT: I've created a Titanium Backup of the Pico TTS then removed it, but the Google Text-to-speech is still a problem.

EDIT2: Found a blog post by wadih's which gives advise to turn off Auto Correction and so far so good. I hope this helps others in case they encounter this problem.

  1. Go to settings.
  2. Go to "language and input"
  3. Go to "Android Keyboard Settings"
  4. Scroll down and click on "Auto Correction"
  5. Choose "OFF"

After your do that Text-to-Speech will stop reading whatever you click on.

Share this post

Link to post
Share on other sites