• Announcements

    • PsychoI3oy

      Unsupported devices & future versions   09/03/16

      Unsupported devices posts outside the Device requests forum will be deleted without comment. Posts asking about/for future versions of CM will be locked and/or deleted.   We don't have a crystal ball; we don't know if someone will make CM $version for your deivce or if CM $version+1 will be made for your supported device.

Archived

This topic is now archived and is closed to further replies.

happy20b

Mobile Network And Wifi Not Working Cm9 On Unlocked At&t Captivate

9 posts in this topic

Dear All,

I have a AT&T captivate . I am in India and the phone has been unlocked using codes provided by AT&T. Right now running official 2.3 ROM. And everything is working fine except few hangs. So I decided to install CM9 ROM which i was able to install successfully. But after installing the ROM, mobile network and WiFi were not working at all . I had installed CM9.0, and now i see CM9.1 which i will install today and let you know if mobile network working.

I am also goin to try CM10 M1. But why mobile network was not working in CM9.0 ? Do i have to unlock cell using AT&T code again ( I have to search for that code now) ? Or do i have to flash any new Radio?

Thanks

Share this post


Link to post
Share on other sites

Was your installation of CM9 one of the release candidates (RC1 / RC2) or was it a nightly? The nightlies are experimental and are usually broken on some level so it is possible to have things like the mobile network, wifi, camera, etc. to not work. CM10 nightlies are working well and I use it as my everyday all-purpose phone. Can't comment on 9.1 as I skipped it and went right to the CM10 nightlies...

Share this post


Link to post
Share on other sites

Sorry forgot to mention.. I had flashed stable CM9.0. Hmm i think better to flash CM10-nightly and try instead of checking with CM9.1 stable.

Will flash today and post it back. But i dont have to unlock the phone again right ?

Share this post


Link to post
Share on other sites

Not sure about having to unlock it again. Do you still have the codes that AT&T gave you in case you need to unlock it again?

CM10 Nightlies have been working great so far. I just flashed the M1 release (you can find it in the nightlies list, it's marked as EXPERIMENTAL-M1) last night. It's supposed to be more stable than nightlies, but not quite a RC. Seems to work well as all of the CM10 nightlies have. I would suggest running a batch backup with Titanium Backup, Do a Nandroid backup, then reset data / clear the cache before installing the CM10 ROM... just to avoid any hiccups.

Good luck and report back!

Share this post


Link to post
Share on other sites

No luck with CM10 nightly also.. WiFi is working though but Mobile network, is not getting detected .. :( :( ...

Please someone help.. flashing back "I897UCKK4 Stock" where everything works fine but it is buggy :/

I tried with CM9 stable and CM10-nigtly .. in both version mobile network is not geting detected :(

I have one doubt.. flashing CM ROMS flashes radio as well ??? Right now it is "Radio (baseband): I897UCKK4"

Thanks in advance

Share this post


Link to post
Share on other sites

Not positive, but I would assume that if there were still issues with CM after flashing the stock modem you should still be able to revert back to the stock ROM. I don't see why it would be a problem, but I've never flashed a different modem so I can't say 100%...

Share this post


Link to post
Share on other sites

Strange.. I thought i will flash CM10 again and then flash stock modem.. Unlike before this time when i flashed CM10.. the mobile network got detected and working :)

Share this post


Link to post
Share on other sites

That's great news! Glad it's working for you now. Now you can enjoy some Jelly Bean goodness!

Share this post


Link to post
Share on other sites