• Announcements

    • PsychoI3oy

      Unsupported devices & future versions   09/03/16

      Unsupported devices posts outside the Device requests forum will be deleted without comment. Posts asking about/for future versions of CM will be locked and/or deleted.   We don't have a crystal ball; we don't know if someone will make CM $version for your deivce or if CM $version+1 will be made for your supported device.
Johnny Nguyen

Reboot Loop at CM7 Screen after Factory Reset

2 posts in this topic

I attempted to do Settings > Privacy > Factory Reset on my T-Mobile Vibrant Galaxy S because it's been Force Closing everything lately and now I just get a Reboot loop where the Cyanogenmod 7 Android rides in on his little skateboard and the arrow travels around him, then it pauses and he rides in again.. and again.. and again.. Please help.. I got this phone when it was already rooted and loaded with this rom. I have never flashed or installed any of this stuff before.

Share this post

Link to post
Share on other sites

Had the same problem today, started experimenting and SOMETHING HAPPENED!! IT WORKED!


Follow these steps,

1) Go into recovery mode (Volume UP + Middle Button + Power Button)

2) Go to backup + restore

3) Restore to internal SD card

4) Factory Reset

5) Go to backup + restore

6) Advance recovery from internal SD Card

6i) Select Data

Hope this works, please tell me if it does!!

Edited by Eeyern Ng

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now