Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse
 

Unfortunately, Android Keyboard (Aosp) Has Stopped.


  • Please log in to reply
30 replies to this topic

#1 bass2k8

bass2k8
  • Members
  • 2 posts
  • Twitter:@benstaker
  • Country:
    uk - United Kingdom
  • Device Model:
    i9100
  • CM Version:
    Nightly Build
  • Recovery Image:
    Cyanogen

Posted 04 April 2013 - 12:16 PM

After updating to CyanogenMod version 10.1-20130404-NIGHTLY-i9100 I can no longer use my keyboard anymore.

It keeps popping up with a message saying "Unfortunately, Android keyboard (AOSP) has stopped."

Here are some screenshots: http://imgur.com/a/nm9DZ

Edited by bass2k8, 04 April 2013 - 12:16 PM.


#2 bassmadrigal

bassmadrigal
  • Administrators
  • 12912 posts
  • Country:
    us - United States
  • Location:
    Newport News, VA
  • Device Model:
    Nexus 4
  • CM Version:
    10.2 Nightlies
  • Recovery Image:
    TWRP

Posted 04 April 2013 - 01:15 PM

What did you upgrade from? Have you tried reflashing the latest gapps package? http://goo.im/gapps

#3 bass2k8

bass2k8
  • Members
  • 2 posts
  • Twitter:@benstaker
  • Country:
    uk - United Kingdom
  • Device Model:
    i9100
  • CM Version:
    Nightly Build
  • Recovery Image:
    Cyanogen

Posted 04 April 2013 - 01:31 PM

 bassmadrigal, on 04 April 2013 - 01:15 PM, said:

What did you upgrade from? Have you tried reflashing the latest gapps package? http://goo.im/gapps

I updated from either 10.1-20130330-NIGHTLY-i9100 or 10.1-20130401-NIGHTLY-i9100 using Cyan Delta. No I have not, I'll try that out now!

#4 bassmadrigal

bassmadrigal
  • Administrators
  • 12912 posts
  • Country:
    us - United States
  • Location:
    Newport News, VA
  • Device Model:
    Nexus 4
  • CM Version:
    10.2 Nightlies
  • Recovery Image:
    TWRP

Posted 04 April 2013 - 01:34 PM

If that doesn't work, you may have just run into a bug with the nightlies. The only way around it would be to install a 3rd-party keyboard, or reverting to a previous nightly.

#5 stefan600

stefan600
  • Members
  • 8 posts
  • Country:
    at - Austria
  • Device Model:
    Samsung Galaxy S2
  • CM Version:
    10.1
  • Recovery Image:
    Cyanogen

Posted 05 April 2013 - 05:18 AM

Had the same problem. I wiped the cache / dalvik cache and also reseted to factory settings. Now it works

#6 Indru

Indru
  • Members
  • 1 posts
  • Country:
    ro - Romania
  • Device Model:
    i9100
  • CM Version:
    JellyBam 7.6.0
  • Recovery Image:
    Other

Posted 06 May 2013 - 07:54 PM

The solution that worked for me is this:

Go into menu/system/apps and find Android Keyboard (ASOP) and CLEAR DATA.  Then do the same for Dictionary Provider and CLEAR DATA. And any other keyboard app you have installed.

I have Jelly Bam 7.6.0.

#7 webmanoffesto

webmanoffesto
  • Members
  • 9 posts
  • Country:
    us - United States
  • Device Model:
    Samsung GT-I9000
  • CM Version:
    Mod
  • Recovery Image:
    Cyanogen

Posted 09 May 2013 - 10:07 AM

 Indru, on 06 May 2013 - 07:54 PM, said:

Go into menu/system/apps and find Android Keyboard (ASOP) and CLEAR DATA.  Then do the same for Dictionary Provider and CLEAR DATA. And any other keyboard app you have installed.

That didn't solve my problem.

It looks like I'm really stuck.

Most of the programs on my phone were crashing almost immediately after I opened them. It looks like I don't have Titanium Backups, because it wasn't running automatically and it became one of the programs which immediately crash.

This might be related to a setting in Contacts which I changed to "sync" and might have caused the "changing contacts to the new language" error I started getting. But it seems to me that SHOULD be set to sync, and anyway I don't know why that would start causing crashes.

I went into Recovery and did Factory Reset and Wipe Cache and Rom'ed CyanogenMod (http://get.cm/get/je...-galaxysmtd.zip) and GApps (http://goo.im/gapps/...1011-signed.zip).

Now when I try to use my phone I get
"unfortunately android keyboard aosp has stopped". That means there is almost nothing I can do because I don't have a keyboard.

I'm really stuck!  :-O

Galaxy S GT-I9000
Android 4.1.2
Cyanogen Mod 10.0.0

Edited by webmanoffesto, 09 May 2013 - 11:16 AM.


#8 bassmadrigal

bassmadrigal
  • Administrators
  • 12912 posts
  • Country:
    us - United States
  • Location:
    Newport News, VA
  • Device Model:
    Nexus 4
  • CM Version:
    10.2 Nightlies
  • Recovery Image:
    TWRP

Posted 13 May 2013 - 07:50 PM

Have you tried formatting the /system partition and then reinstalling CM and gapps?

#9 h4rr0d

h4rr0d
  • Members
  • 2 posts
  • Country:
    cz - Czech Republic
  • Device Model:
    Samsung Galaxy S II
  • CM Version:
    10.1
  • Recovery Image:
    ClockworkMod

Posted 15 May 2013 - 10:36 AM

 Indru, on 06 May 2013 - 07:54 PM, said:

The solution that worked for me is this:

Go into menu/system/apps and find Android Keyboard (ASOP) and CLEAR DATA.  Then do the same for Dictionary Provider and CLEAR DATA. And any other keyboard app you have installed.

I have Jelly Bam 7.6.0.

Worked for me as well on cm-10.1-20130514-NIGHTLY-i9100

#10 MikeViller

MikeViller
  • Members
  • 87 posts
  • Country:
    ca - Canada
  • Device Model:
    GT-I9100M
  • CM Version:
    CM10.2
  • Recovery Image:
    ClockworkMod

Posted 15 May 2013 - 12:19 PM

do not know witch update did it but I upgrade from the 10 I thing to the 15 and had the keyboard error the clear data work for me.

#11 mmeganleannee

mmeganleannee
  • Members
  • 1 posts
  • Country:
    us - United States
  • Device Model:
    samsung sgh-t989
  • CM Version:
    10
  • Recovery Image:
    ClockworkMod

Posted 19 June 2013 - 08:31 AM

I have the Galaxy S2 Hercules for T-Mobile and I added the CM10 to my phone. I accidentally downloaded the wrong GApp I think, and my keyboard will not work. I downloaded the right GApp but I don't know how to get rid of the other one and make my keyboard work!!

#12 bassmadrigal

bassmadrigal
  • Administrators
  • 12912 posts
  • Country:
    us - United States
  • Location:
    Newport News, VA
  • Device Model:
    Nexus 4
  • CM Version:
    10.2 Nightlies
  • Recovery Image:
    TWRP

Posted 19 June 2013 - 01:25 PM

You should be able to just flash it over the other one. You may need to clear the data for the keyboard.

#13 beedee101

beedee101
  • Members
  • 3 posts
  • Country:
    au - Australia
  • Device Model:
    Samsung Galaxy S2
  • CM Version:
    CyanogenMod-7-11152011-NIGHTLYGalaxyS2
  • Recovery Image:
    Cyanogen

Posted 31 July 2013 - 12:07 AM

 Indru, on 06 May 2013 - 07:54 PM, said:

The solution that worked for me is this:

Go into menu/system/apps and find Android Keyboard (ASOP) and CLEAR DATA.  Then do the same for Dictionary Provider and CLEAR DATA. And any other keyboard app you have installed.

I have Jelly Bam 7.6.0.

This solution worked for me also, going into FORCE STOP each of the app before CLEAR DATA.

Problem appear to start happening after some of the Google apps updates. Google+, Hangouts.

Am using 10.1-20130324-NIGHTLY-i9100

#14 jestexploit

jestexploit
  • Members
  • 1 posts
  • Twitter:jestexploit
  • Country:
    ph - Philippines
  • Device Model:
    GT-i9100
  • CM Version:
    10.1-20130725-NIGHTLY-i9100
  • Recovery Image:
    ClockworkMod

Posted 02 August 2013 - 03:19 AM

 Indru, on 06 May 2013 - 07:54 PM, said:

The solution that worked for me is this:

Go into menu/system/apps and find Android Keyboard (ASOP) and CLEAR DATA.  Then do the same for Dictionary Provider and CLEAR DATA. And any other keyboard app you have installed.

I have Jelly Bam 7.6.0.


Worked for me.

#15 gearfreak

gearfreak
  • Members
  • 5 posts
  • Country:
    us - United States
  • Device Model:
    SCH-I800
  • CM Version:
    CM10
  • Recovery Image:
    ClockworkMod

Posted 11 August 2013 - 07:13 PM

 Indru, on 06 May 2013 - 07:54 PM, said:

The solution that worked for me is this:

Go into menu/system/apps and find Android Keyboard (ASOP) and CLEAR DATA.  Then do the same for Dictionary Provider and CLEAR DATA. And any other keyboard app you have installed.

I have Jelly Bam 7.6.0.

I got a galaxy tab 7" but I'm experiencing the same issues like the OP.

Disabling the android keyboard worked for me but I had to flash gapps-jb-20121011 instead of the latest gapps-jb-20130301.

For some reason all of the google apps were crashing even when the keyboard was disabled until I flashed the older 20121011 version.

I have a physical docking keyboard which I used to connect to wifi and was able to search for a swype keyboard in the play store. Those without a keyboard will have to get the apk, put it on the SD card, and then manually installing it.

#16 lepirlouit

lepirlouit
  • Members
  • 2 posts
  • Country:
    be - Belgium
  • Device Model:
    Xperia S
  • CM Version:
    10.1
  • Recovery Image:
    Cyanogen

Posted 16 August 2013 - 08:44 AM

Same issue with gapps-jb-20130813-signed.zip issue solved by installing gapps-jb-20130301-signed.zip and wipe the cache.

#17 Lusent

Lusent
  • Members
  • 3 posts
  • Country:
    us - United States
  • Device Model:
    Nexus 7 Gen 1 Grouper
  • CM Version:
    Cyanogen 10.2 Nightlies
  • Recovery Image:
    TWRP

Posted 19 August 2013 - 12:09 AM

 lepirlouit, on 16 August 2013 - 08:44 AM, said:

Same issue with gapps-jb-20130813-signed.zip issue solved by installing gapps-jb-20130301-signed.zip and wipe the cache.

Very pleased to say that this suggestion worked for me. I was having the exact same problems as bass2k8 (OP), and after doing what was suggested here it fixed the problem.

Using Nexus 7 2012 (first generation tablet) with version 10.1.2(grouper) cyanogen.

#18 lepirlouit

lepirlouit
  • Members
  • 2 posts
  • Country:
    be - Belgium
  • Device Model:
    Xperia S
  • CM Version:
    10.1
  • Recovery Image:
    Cyanogen

Posted 22 August 2013 - 06:43 AM

Now i have read the first table on page : http://goo.im/gapps
that says : Use this table to figure out which package you need!
So now I just installed the last version for CM 10.1.x android version 4.2.2 meaning 20130812

#19 badabing77

badabing77
  • Members
  • 3 posts
  • Country:
    us - United States
  • Location:
    Capitola, CA
  • Device Model:
    Kindle Fire 1st Gen
  • CM Version:
    10.1.2
  • Recovery Image:
    Cyanogen

Posted 07 September 2013 - 09:35 PM

Same keyboard "stopped" issue (Kindle Fire 1st Gen, 10.2.1) resolved same as #16 above. I went into Recovery mode, did a USB mount, and transferred gapps-jb-20130301-signed.zip from my PC and installed.
All is sweet now.

#20 palmtree

palmtree
  • Members
  • 1 posts
  • Country:
    th - Thailand
  • Device Model:
    Kindle Fire V1
  • CM Version:
    10.2
  • Recovery Image:
    Cyanogen

Posted 13 September 2013 - 10:14 AM

 badabing77, on 07 September 2013 - 09:35 PM, said:

Same keyboard "stopped" issue (Kindle Fire 1st Gen, 10.2.1) resolved same as #16 above. I went into Recovery mode, did a USB mount, and transferred gapps-jb-20130301-signed.zip from my PC and installed.
All is sweet now.

Had the same problem with the same setup (kindle Fire V1, 10.2.) and jb 2013 03 01 solved it. (which is in the wrong thread here, I know. But google brought me here for the solution)
Can be found here  http://goo.im/gapps/...signed.zip  (or use google, I got it from a shared gdrive and compared the md5-sums)

Edited by palmtree, 13 September 2013 - 10:15 AM.