Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse

(SOLVED)not able to get root Rogers Dream: Rooting (911 Patched)

rogers exploid

This topic has been archived. This means that you cannot reply to this topic.
6 replies to this topic

#1 dogbite3

  • Members
  • 7 posts

Posted 23 March 2012 - 03:22 AM

I have a rogers htc dream  g1
baseband 62.59S.20.23U_3.22.26.17
runing firmware 1.5

build number 1.89.631.1 cl#9414 release-keys

I am running debian
I am following the http://wiki.cyanogen...eam_911_Patched link

I have no problems til I get to the #8

"Rooting the Rogers Dream & Installing Amon_Ra's Recovery"

when I run exploid it, well it does not run.

$ enduser@debian:~/android-sdk-linux/platform-tools$ ./adb shell
$ cd /sqlite_stmt_journals
$ chmod 777 /sqlite_stmt_journals/exploid
$ ./exploid
[1] + Stopped (signal)        ./exploid

not really sure what to do at this point. Maybe I am not searching the proper terms I am not finding any answers.

$ rootshell
rootshell: permission denied

is not going to get me anyware?

can someone who has done the rogers htc dream give me a tip
i don't want to reboot it till I know for sure ..  i have read my share for the day and with all the fear of bricking I wanna leave it be and see what someone else has to say!

Edited by dogbite3, 03 April 2012 - 11:44 PM.

#2 dogbite3

  • Members
  • 7 posts

Posted 25 March 2012 - 02:59 PM

Should I be doing something else because of my radio or something.  I think only info I forgot is my


kernel version
u70000@Android-x01 #12

build number
1.89.631.1 cl#9414 release-keys

SOunds like I might need to be doing this from a post I read (translated from russian)

seems I should do this
Although I am worried about what they say about SPL?! its not clear if person had a problem and bricked it?  

I will let everyone know here how I made out

#3 dogbite3

  • Members
  • 7 posts

Posted 27 March 2012 - 01:42 AM

I am still unable to continue rooting dream htc g1!

I am thinking they did something to this phone that made it so it stops the exploid file from running (stopping it like that)  maybe I can find anouther dir to run it from or maybe change the name anyone? any idea?

#4 dogbite3

  • Members
  • 7 posts

Posted 28 March 2012 - 09:04 PM

ugh help

#5 dogbite3

  • Members
  • 7 posts

Posted 03 April 2012 - 04:33 PM

after reading  when ever I had time about my current phones softwares and versions. Its clear at the time of this posting that there seems to be no way to root said phone.

I keep thinking at the back of my head that I missed a link on some one click method to backup and change a image file.  but most fourm links I read seem to interlink to them selves and it seems this phone is not as popular anymore.

I like this phone for the ready available parts and the fact that its simple  its a shame its falling through the cracks.

if anyone does have a way around this I will have to sell off my unrootable phone

and start looking for a phone that is rootable thats bit faster . that has a keyboard and is reliable .

#6 dogbite3

  • Members
  • 7 posts

Posted 03 April 2012 - 10:29 PM

There seems to be no way to erase old posts.

I found anouther post
that led me to

now I just changed the exploid file that I was originally using that was only 9.5KB with one thats 11KB and well you can see how far I have got
http://rapidshare.co...id.zip.html  If this disapears I will upload someplace

enduser@debian:~/android-sdk-linux/platform-tools$ ./adb push spl-signed.zip /sdcard/1_33_2005_spl.zip
986 KB/s (188246 bytes in 0.186s)
enduser@debian:~/android-sdk-linux/platform-tools$ ./adb push recovery-RA-dream-v1.7.0R-cyan.img /data/local
2 KB/s (180 bytes in 0.062s)
enduser@debian:~/android-sdk-linux/platform-tools$ ./adb push exploid /sqlite_stmt_journals
242 KB/s (11917 bytes in 0.047s)
enduser@debian:~/android-sdk-linux/platform-tools$ ./adb shell chmod 777 /sqlite_stmt_journals/exploid
enduser@debian:~/android-sdk-linux/platform-tools$ ./adb shell /sqlite_stmt_journals/exploid
[*] Android local root exploid © The Android Exploid Crew
[*] Modified by birdman for the DroidX
[+] Using basedir=/sqlite_stmt_journals, path=/sqlite_stmt_journals/exploid
[+] opening NETLINK_KOBJECT_UEVENT socket
[+] sending add message ...
[*] Try to invoke hotplug now, clicking at the wireless
[*] settings, plugin USB key etc.
[*] You succeeded if you find /system/bin/rootshell.
[*] GUI might hang/restart meanwhile so be patient.
enduser@debian:~/android-sdk-linux/platform-tools$ ./adb shell
$ rootshell
Password (echoed):secretlol
# chmod 666 /dev/mtd/mtd1
# exit
$ flash_image recovery /data/local/recovery-RA-dream-v1.7.0R-cyan.img
error reading /data/local/recovery-RA-dream-v1.7.0R-cyan.img
$ flash_image recovery /data/local/recovery-RA-dream-v1.7.0R-cyan.img
error reading /data/local/recovery-RA-dream-v1.7.0R-cyan.img

currently, I am stuck here. flash_image can not read  /data/local/recovery-RA-dream-v1.7.0R-cyan.img.  I chmod 666 /data/local/recovery-RA-dream-v1.7.0R-cyan.img for luck and still nothing.

well some progress recovery-RA-dream-v1.7.0R-cyan.img is 180k  I am going to double check that

#7 dogbite3

  • Members
  • 7 posts

Posted 03 April 2012 - 11:40 PM

It was just the size of the recovery-RA-dream-v1.7.0R-cyan.img (it should of been 4.5 megs)  nice it went quick

enduser@debian:~/android-sdk-linux/platform-tools$ ./adb push recovery-RA-dream-v1.7.0R-cyan.img /data/local
1275 KB/s (4712448 bytes in 3.606s)
enduser@debian:~/android-sdk-linux/platform-tools$ ./adb shell
$ flash_image recovery /data/local/recovery-RA-dream-v1.7.0R-cyan.img
$ flash_image recovery /data/local/recovery-RA-dream-v1.7.0R-cyan.img
$ exit

and a power down and power up holding the home key in showed it worked I had the words
Build : RA-dream-v1.7.OR  at the very bottom of the greenish blue menu options  way more options nice..

now to attempt the http://wiki.cyanogen...:_DangerSPL  so I can actually do something
spl-signed.zip 183.8 kb

when I selected the DangerSPL in the recovery menu (Alt+F)Flash zip from sdcard It was quick then I rebooted . once I rebooted it right away went into same recovery menu (home held while powering up was not nessary) and I could see it was doing some formating

Build : RA-dream-v1.7.OR
formating CACHE:...

I waited  menu allowed me to scroll around so I dunno..  powered it down
it rebooted to normal rogers crap .. so I shut it down.

then holding the camera key  while powering it up it finnaly said hboot-1.33.2005  
so I managed to get DangerSPL working

so now on to cm6

After this it would be a good idea to hold home and power up to the recovery menu and wipe all the data to factory  heck run all of the items in the menu.  when I booted up I had all sorts of error messages from the previous stock images settings

cm 6 takes alot longer to boot then stock firmware
I would say a good 2 minsfinished

well there you go all the old posts  there was one that showed its still possible to root a 1.89.631.1 Build enjoy