Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse
 

Package file invalid


  • Please log in to reply
2 replies to this topic

#1 jacr13

jacr13
  • Members
  • 2 posts
  • Twitter:jacr13
  • Device Model:
    |2|
  • CM Version:
    5.0.7
  • Recovery Image:
    Cyanogen

Posted 02 June 2010 - 08:45 AM

Hello

I have done a lot of searching but still am stuck with this problem. Since updating to the latest Cyanogen Rom, I am getting a lot of "package file invalid" errors when trying to install or upgrade apps. Some will go through ok, others display the message I have just mentioned. Really, I am stuck! I do not have a clue what to do and can't find anything though searching that will help. Just remembered, a lot of apps also crash whilst running, not sure if that is a related issue.

I have attached a log file though really, I have no idea what any of it means!

Any and all help appreciated.

Attached Files

  • Attached File  log.txt   28.8K   1 downloads


#2 ciwrl

ciwrl

    Whose bright idea was it to put me in charge?

  • Administrators
  • 1625 posts
  • Twitter:ciwrl
  • Country:
    us - United States
  • Device Model:
    DS|N1|NS|G2|SGS|SGN|N4|N5
  • CM Version:
    [Latest]
  • Recovery Image:
    ClockworkMod

Posted 02 June 2010 - 09:04 AM

In terminal:

su
fix_permissions

Also, are you running app2sd, and accidentally allow for the sdcard to be removed while the phone was powered on?

#3 jacr13

jacr13
  • Members
  • 2 posts
  • Twitter:jacr13
  • Device Model:
    |2|
  • CM Version:
    5.0.7
  • Recovery Image:
    Cyanogen

Posted 02 June 2010 - 09:08 AM

Hello. Yes I am running app2sd and no I have not removed the memory card. I have run fix permissions. I also have wiped and reinstalled the rom. The one thing I was wondering from searching was perhaps my partition sizes on sd card are wrong? I wouldn't know though, nor would I know to how to check! Also this would not explain how some apps install, yet others do not.

View Postciwrl, on 02 June 2010 - 09:04 AM, said:

In terminal:

su
fix_permissions

Also, are you running app2sd, and accidentally allow for the sdcard to be removed while the phone was powered on?