Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse

"Package file is invalid"

storage market packages

  • Please log in to reply
2 replies to this topic

#1 lsiden

  • Members
  • 11 posts
  • Twitter:lsiden
  • Country:
    us - United States
  • Location:
    Ann Arbor, MI
  • Device Model:
    HTC Evo 4g PC36100
  • CM Version:
  • Recovery Image:

Posted 17 January 2012 - 09:21 PM

My Evo 4G has been plagued by "Package file is invalid" errors when attempting to install or update many Market apps.  After reading many posts, I've tried the following:
  • Updating to CM 7.1 and the latest gapps as per this earlier helpful post.
  • I have I upgraded to a new Type 10 SD card, created a new ext3 partition, and moved as many apps as I could to the SD card
  • Installed link2sd to manage it all,
  • wiped the cache and data for the Market App
  • Cleaned the Dalvik cache
  • Wiped the Dalvik cache

The only thing I wasn't able to do is to rename /cache/download so that I could soft-link it to /sd-card/cache/download by hand. (may have the paths wrong).  It kept responding with something like "Can't rename /cache/download; file or device is busy" (not sure of exact wording).  Anyway, that may have been taken care of by link2sd now.

I know that this isn't specifically a CM7 issue, but that's what I have installed and I figured developers on this forum should have a better idea than most casual users.  I can identify with Brian's frustration in the thread previously mentioned, because many people seem to have this problem there is indeed scant little good information on how to fix this other than "Try wiping your cache, then wiping your phone if that doesn't work".  There has got to be a better way to resolve this!

I wonder if there is a way to resize the cache, because I don't know what's left that I can try.

For the record, the About Phone page says I have CM-7-11162011-NIGHTLY-Supersonic with Android version 2.3.7

On the same page, under Mem info, says 198/414 Mb for avail/total (different than what it said on the "Storage" page.

Let me know if there is any other info I can provide.

#2 Cloonix

  • Members
  • 44 posts
  • Twitter:Cloonix
  • Country:
    de - Germany
  • Location:
  • Device Model:
    HTC Desire Z
  • CM Version:
    CM7 #263
  • Recovery Image:

Posted 18 January 2012 - 10:03 AM

I have this problem since Monday HTC Desire Z/Vision and can't figure out why. My partitions are all below 20% full (df -m). I tried everything I could find on the Internet (wipe cache, wipe .android_secure).

#3 spenwah

  • Members
  • 2 posts
  • Device Model:
    LG Vortex
  • CM Version:
    CM 7.1
  • Recovery Image:

Posted 15 February 2012 - 07:31 AM

I have been having this problem relentlessly ever since I got my LG Vortex a year ago. The Vortex is an entry level "free" phone with a notoriously small internal memory. About two months ago I finally learned how to root the phone (apparently it's also a hard one to root successfully), and the problem went away, for a while. But now it's back.

I have: cleared Market cache and data, onetouch cache clear, recovery wipe cache, wipe Dalvik cache
The problem happens whether I download via WiFi or 3G, and it doesn't seem to matter whether it's an update, a fresh install, or a new app I have never tried before. Usually I can remove one app and install another.

I have plenty of internal memory space. But, my /cache folder is always nearly full at 89MB with 1MB free, even after cache wipe and Dalvik wipe. All of this is in the folder /cache/dalvik-cache, all dex files.

Now, I also have a folder /data/dalvik-cache, which is 112MB with 73MB remaining free. Is it unusual to have two such DC folders? I once used an app from the Market called "MarketFix." Miraculously, it instantly solved the problem, but only for a while. The problem eventually came back, and now I can still run MarketFix but it doesn't fix anything. Maybe MF did a good job the first time I used it and made a new cache area in /data, but sometime later the system rebuilt everything back in /cache?

Actually, now that I look more closely... and I'm not really sure if I'm seeing this correctly... but it looks like if I delete from /data/dalvik-cache, the same file also disappears from /cache/dalvik-cache... the plot thickens.

I suspect the best solution would involve enlarging the cache space, but I guess that must be hard to do because I have not heard of anyone trying. In the past I "fixed" the problem by using the app Link2SD, which does move Dalvik, cache, and data files onto a special partition of the SD card. But then I had problems trying to restore backups and decided it wasn't worth it...

Edited by spenwah, 15 February 2012 - 07:34 AM.