Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse

Error: E:"Failed to verify whole-file signature"

  • Please log in to reply
5 replies to this topic

#1 Marcusio

  • Members
  • 1 posts
  • Device Model:
    Galaxy S2 GT 19100
  • CM Version:
    Gingerbread EG30
  • Recovery Image:

Posted 29 December 2011 - 01:34 AM

I apologize for bumping up a topic that was started so long ago, but I am at wit's end with my issue and this thread is the closest to anything that I've seen so far on the web.

I have a Galaxy S2 GT -19100 from Sprint.  I am fairly computer/tech savvy and previously had an iphone which I jailbroke, but have moved on to the wonderful, open architecture of Android.

Right out the box I downloaded Odin and quickly figured out how to root the phone.  After customizing it and downloading numerous apps, I quickly realized that phone has a bug that causes it to drop calls and lose it's signal.  I waited patiently for an update, however when the update finally came out, it was apparent that my phone would not update.  It would try to reboot and then it would hang on the message of E:"Failed to verify whole-file signature".  Like many of the others here, I tried some simple solutions such as wiping out the data and doing a factory reset.  When I tried solutions that involved loading something from the SD card, it gives an error that it won't mount.  I don't know if that's because it is looking for an external card (which it doesn't have) or if it's not "mounting" the internal one.  I was hopeful to get my phone off of Gingerbread and onto Cyanogen, but I seem be a ways away from that.

I have ROM Manager on my phone which has a Clockwork Mod Recovery option that I tried using, but like the example above, it hangs on the same message.

Another site suggested that when something like this happens, you need to flash the kernel.  I was going to try and use Odin to do that, but I am unsure of which kernel would be appropriate.  Half the problem seems to be figuring out which kernel I currently have.  I do not seem to be getting the same information as other get when looking at "About Phone" in the settings.

Here are all of my specs:

Model number: SPH-D710
Android Version: 2.3.4
Baseband version: s:D710.10 S.EG30
Build version: Gingerbread.EG30
Kernel version:

Other websites tell you to find your kernel version by checking the phone and that it should be something like: root@DELL106.  All I have is

So there's my situation.  Any advice??  :mellow:

Edited by Marcusio, 29 December 2011 - 04:32 PM.


  • Members
  • 14 posts
  • Twitter:Rune Luk
  • Country:
    dk - Denmark
  • Location:
  • Device Model:
    Samsung Galaxy Nexus
  • CM Version:
    CM10 Nightlies Bean 4.1.2
  • Recovery Image:

Posted 30 December 2011 - 07:59 AM

If the phone isn't rooted properly it can cause the "Failed to verify whole-file signature"-problem. Try rooting it again, that was how I solved it.

Edited by RLUK, 30 December 2011 - 07:59 AM.

#3 nubreed000

  • Members
  • 14 posts
  • Device Model:
    samsung galaxy s2
  • CM Version:
    gt i9100m
  • Recovery Image:

Posted 25 January 2012 - 03:42 PM

View PostDead Soul, on 12 October 2011 - 03:18 PM, said:

Guys got it working

WIPE user data + dalvik cache on ur SD Card  with cwm recovery
Flash the ROM Twice with CWM Recovery AND I REALLY MEAN TWICE
before u perform a reboot
Yous samsung galaxy s 2 will work fine...!!


let me know how it goes

So let me get this straight: go into recovery and let it fail the verification...and then select which options exactly?
Here's what I have:
-apply update from sd
-wipe data/factory reset
-wipe cache partition
-install zip from sd
-back up and restore
-mounts and storage
-power off

Also here's my phone details are this, let me know if the kernel and baseband versions not matching will somehow create a problem: (I tried reverting back to 2.3.5 last night but somehow I'm still on 2.3.6 but the kernel is older...)

Android version: 2.3.6
Baseband: I9100XXKL1

edit: so I wiped user data/factory reset, the wiped cache partition (dunno where you got the dalvik thing from) installed update-cm-7.1.0-GalaxyS2-signed.zip from sd card TWICE like you said and now my phone is caught in a start up loop. Gonna try reflashing 2.3.6 back onto it.

edit 2:k fixed it. until somebody comes up with an actual solution to this i'm not gonna bother wasting any more time on this.

Edited by nubreed000, 25 January 2012 - 04:16 PM.

#4 nubreed000

  • Members
  • 14 posts
  • Device Model:
    samsung galaxy s2
  • CM Version:
    gt i9100m
  • Recovery Image:

Posted 25 January 2012 - 05:45 PM

View Postswisshardy, on 11 October 2011 - 02:04 AM, said:

Hi Guys

I finally got CM to work. the way i did it was to install KG3(2.3.4) version instead of my KI3(2.3.5) and while doing that do not use the external sd card(dont insert it into the phone). After installing KG3, i installed the CF root and downloaded the CM nightly 77 and use CWM to reboot in recovery mod and wipe factory settings and data and dalvik cache and do flash the new cm update twice and then install the google apps and hey presto, my sgs2 booted with cm7.

I think what i was doing wrong was that before after rooting with insecure kernel and i would put the stock kernel back on the phone so that i dont see the yellow triangle everytime i reboot the phone. I clicked while reading in one of the posts above that the stock receovery(3e) comes into place when it sees a stock samsung kernel and thats why i wasnt able to see the CWM after flashing twice and rebooting the phone. So in short  do not put a stock kernel after rooting and it might work for you.

Now i can sleep peacefully tonight...

That's weird because all I do is simply install 2.3.6KL1; run the CF Root process and then go into Recovery mode, wipe whatever needs wiping and install from SD. I reboot and get stuck on the boot up...it just keeps turning on off...shows the Galaxy SII logo and then shuts itself off. On and on. Can't access recovery so I have to run Odin all over again and reinstall 2.3.6KL1.

#5 John Tissington

John Tissington
  • Members
  • 1 posts

Posted 28 January 2012 - 09:55 PM

View PostApocangel, on 19 August 2011 - 03:47 PM, said:

Here. Follow this guide. Worked perfectly well for me.

now i keep getting a  ! next to a android when I to install a rom, even though I have checked permissions.

Edited by John Tissington, 28 January 2012 - 10:15 PM.


  • Members
  • 2 posts
  • Country:
    us - United States
  • Location:
    Mile High City
  • Device Model:
    HTC Incredible ADR6300
  • CM Version:
  • Recovery Image:

Posted 02 February 2012 - 08:49 PM

If you get failed to verify message its either cuz u do not have s-off (NAND unlocked) or you need to disabe signature verifiacation within ur recovery options. You can download zipsigner or signapktic from the market and sign ur own zip files with various keys (auto,test,media,etc etc) though i advise doing this with caution as u should already be aware of the risks of flashing unsigned zips. You should also make sure b4 u do anything at all MAKE A NANDROID BACKUP OF YOUR PHONE!!! Another thing i see that keeps coming up is some of u are using rom manager app to install ur update, Kush is a great developer with quality programs however as of late its been sketchy and has caused some problems with some devices ( USB and SDCARD were bricked from flashing through the app on my Droid Inc~though i was able to fix it~ ) maybe try only flashing by booting to recovery directly, sometimes u may need to wipe cache/dalvik a few times BEFORE trying to flash an update. If that still fails u can try a complete wipe ( if u use titanium backup pro b4 u wipe u can restore all sytem and/or user app and/or data with a simple click ) your next option is to try and flash an alternate recovery then try to flash ur update. If all that fails i would say its not worth the risk of flashin !sometimes theres a reason u cant flash a file. Last thing i thought of is check ur file is named correctly if u rename a file make sure its not accidentally named update.zip.zip as that can be a common error. Good Luck!

Edited by IVXX, 02 February 2012 - 08:51 PM.