Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse
 

S=Off but no root access?


  • Please log in to reply
3 replies to this topic

#1 doctorklon

doctorklon
  • Members
  • 2 posts
  • Device Model:
    HTC Glacier
  • CM Version:
    stock
  • Recovery Image:
    TWRP

Posted 24 March 2011 - 01:32 AM

New to the forum...just switched from a breaking N1 to the MT4G and trying to get CM7 on it. Rooting was pretty simple on the N1 but I'm running into problems on the MT4G.

I went through the wiki, pushed the files into the phone via adb, etc.

If I power on while holding power+volume, I get S=OFF, but when I go into Rom Manager, it says that I don't have root privileges. If I go into a terminal emulator and type SU it says permission denied.

When I was following the wiki, on the step when I'm supposed to put  "/data/local/tmp/root" into the terminal emulator, it has error messages all over the place including not being able to execute busybox, so I figure that is the problem?

gfree ran fine with no errors.

I've tried re-pushing the files to make sure that I put them in the right place, but no matter what I do it won't execute the root command...

Ideas? (Thanks in advance).

#2 doctorklon

doctorklon
  • Members
  • 2 posts
  • Device Model:
    HTC Glacier
  • CM Version:
    stock
  • Recovery Image:
    TWRP

Posted 24 March 2011 - 04:34 AM

Nevermind...figured it out.

After using the HTC Sense BS for a week I'm glad to have a real phone again.

#3 ikesik

ikesik
  • Members
  • 2 posts
  • Device Model:
    HTC Glacier
  • CM Version:
    6.1
  • Recovery Image:
    ClockworkMod

Posted 26 March 2011 - 05:38 PM

View Postdoctorklon, on 24 March 2011 - 01:32 AM, said:

New to the forum...just switched from a breaking N1 to the MT4G and trying to get CM7 on it. Rooting was pretty simple on the N1 but I'm running into problems on the MT4G.

I went through the wiki, pushed the files into the phone via adb, etc.

If I power on while holding power+volume, I get S=OFF, but when I go into Rom Manager, it says that I don't have root privileges. If I go into a terminal emulator and type SU it says permission denied.

When I was following the wiki, on the step when I'm supposed to put  "/data/local/tmp/root" into the terminal emulator, it has error messages all over the place including not being able to execute busybox, so I figure that is the problem?

gfree ran fine with no errors.

I've tried re-pushing the files to make sure that I put them in the right place, but no matter what I do it won't execute the root command...

Ideas? (Thanks in advance).

I had an issue like this with my wife's phone.  follow this method: http://forum.xda-dev...ad.php?t=834225 and if at the end it still doesnt work, I found that simply telling VISIONary to attempt permroot and rebooting works fine.  Worked for me anyway.  So basically, follow all those steps to gain s=off if you havent.  then get temproot from visionary.  then attempt permroot.  then reboot and your rooted.  at least I was.  Good luck

EDIT: Oops...didnt see the nevermind part.  Oh well, maybe someone else is helped by this :P

Edited by ikesik, 26 March 2011 - 05:40 PM.


#4 ciwrl

ciwrl

    Whose bright idea was it to put me in charge?

  • Administrators
  • 1625 posts
  • Twitter:ciwrl
  • Country:
    us - United States
  • Device Model:
    DS|N1|NS|G2|SGS|SGN|N4|N5
  • CM Version:
    [Latest]
  • Recovery Image:
    ClockworkMod

Posted 29 March 2011 - 07:28 AM

Just to touch base on this, it is related to the busybox binary on the CM wiki.

We've gone ahead and replaced the 'bad' one about 3 hours ago from this post.

Thanks for all of you who lets us know about the compatibility issues