Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse
 

Black screen during a call


  • Please log in to reply
37 replies to this topic

#21 OnkoKubo

OnkoKubo
  • Members
  • 2 posts
  • Country:
    sk - Slovakia
  • Device Model:
    ZTE Blade
  • CM Version:
    Cyanogen 7 RC2
  • Recovery Image:
    ClockworkMod

Posted 14 March 2011 - 07:29 AM

Hi. I have the same problem. I found a little workaround. After screen stays black I dial ZTE's phone number and I leave a missed call. After this pattern unlock screen appears (I have set this) and display is working again. Seems to me this is caused by default unlock screen app, that is used for call answering, too. Is it possible?

#22 3ftw

3ftw
  • Members
  • 16 posts
  • Twitter:3ftw
  • Device Model:
    ZTE Blade
  • CM Version:
    CyanogenMod 7 for Blade :: V7.0.0-RC2
  • Recovery Image:
    ClockworkMod

Posted 14 March 2011 - 04:48 PM

guys i have the same problem...plz help me..

#23 jzaw

jzaw
  • Members
  • 5 posts
  • Country:
    uk - United Kingdom
  • Device Model:
    ZTE Blade
  • CM Version:
    CM7 nightly 18
  • Recovery Image:
    ClockworkMod

Posted 14 March 2011 - 11:16 PM

 dede_lecochon, on 13 March 2011 - 09:13 PM, said:

tried this

with nightly 18 - seems that no more trouble with black screen. many thanks, jzaw!
(with RC1 & 2 i had this problem)

glad it's helped

I've found the issue with swmbo's blade
but in that case I went from rc1 to rc2 and it started to exhibit the black screen issue
I reverted to nightly 12 then nightly 18 and now 19 (wiping cache and wiping delvik cache between each)

now it still goes black

having set the ALWAYS USE PROXIMITY setting to YES
Ive found that if i put my finger horizontally across the top of the phone (while black during or after a call) thus activate the proximity sensor at the top there near the ear piece
the screen now seemed to return (but just for a second)
and when I let go and place my finger back on the sensor there
the screen comes back ... disappears .... and when I take my finger away REAPPEARS this time permanently
and I can kill the call

wonder if anyone else has noticed this


now I have my blade working correctly and swmbo's for which I have a work-around as above

its as if my blade which has had every nightly build one after the other has had something left behind by one of the builds
where as swmbo's blade which jumped from rc1 practically to 18 and 19 missing most of the other builds is missing something

#24 jzaw

jzaw
  • Members
  • 5 posts
  • Country:
    uk - United Kingdom
  • Device Model:
    ZTE Blade
  • CM Version:
    CM7 nightly 18
  • Recovery Image:
    ClockworkMod

Posted 15 March 2011 - 11:14 PM

from another thread on this forum suggesting a reboot (once ALWAYS USE PROXIMITY is set) I can confirm the phone works correctly again
(blade nightly 19)

but I have a suspicion I'll be reporting that it has reverted to staying black during/after a call

#25 3ftw

3ftw
  • Members
  • 16 posts
  • Twitter:3ftw
  • Device Model:
    ZTE Blade
  • CM Version:
    CyanogenMod 7 for Blade :: V7.0.0-RC2
  • Recovery Image:
    ClockworkMod

Posted 16 March 2011 - 06:58 AM

my phone works well to...i have N19 and i put "always use proximity" to off but i have download roottools.apk and i put the proximity delay to 450 and works well..try it..(reboot required)

#26 eLJay

eLJay
  • Members
  • 43 posts
  • Country:
    uk - United Kingdom
  • Device Model:
    ZTE Blade
  • CM Version:
    Latest Nightly Build
  • Recovery Image:
    ClockworkMod

Posted 16 March 2011 - 02:41 PM

 3ftw, on 16 March 2011 - 06:58 AM, said:

my phone works well to...i have N19 and i put "always use proximity" to off but i have download roottools.apk and i put the proximity delay to 450 and works well..try it..(reboot required)

I had the same problem using N15, answer a call and then have to rip the battery out to get the phone back up and running as it didn't respond. Try looking in the settings in either ADW Launcher or CyanoGenMod settings, I tweaked something in there and its now fine (might have been the fancy screen close and open setting I switched off). I have moved it up to N21 so hopefully thats fixed in there anyway (or my tweaking already has that sorted).

#27 eLJay

eLJay
  • Members
  • 43 posts
  • Country:
    uk - United Kingdom
  • Device Model:
    ZTE Blade
  • CM Version:
    Latest Nightly Build
  • Recovery Image:
    ClockworkMod

Posted 17 March 2011 - 12:02 PM

 eLJay, on 16 March 2011 - 02:41 PM, said:

I had the same problem using N15, answer a call and then have to rip the battery out to get the phone back up and running as it didn't respond. Try looking in the settings in either ADW Launcher or CyanoGenMod settings, I tweaked something in there and its now fine (might have been the fancy screen close and open setting I switched off). I have moved it up to N21 so hopefully thats fixed in there anyway (or my tweaking already has that sorted).

Juat read elsewhere its due to the length of the call (2 minutes) so my phone still locks up and the shake software solution is limited to 8 shakes a day. I'll keep updating and see if there is a fix.

#28 Ogami Itto

Ogami Itto
  • Donators
  • 33 posts
  • Country:
    fr - France
  • Device Model:
    ZTE Blade
  • CM Version:
    CM7 N72 modified
  • Recovery Image:
    ClockworkMod

Posted 17 March 2011 - 01:39 PM

Hi.
I may have found a solution to this very annoying problem - well at least people who still face it should give this a try...
I think that earlier in this thread or in another one on this forum someone explained how to trigger the proximity sensor: I happened to test this, and it worked - notably when, after a call, my screen wouldn't switch on.
So when this happens try to put your forefinger horizontally on the top of the screen, as to hide the earpiece, and then remove it. Try a few times if it does not work instantly.
Looks like there's something wrong with this sensor, either hardware or software.
In the end I'm really not sure whether this is linked to the mod: I almost didn't use the original mod for my phone so I have no possible comparison, and it also seemed to me that the sensor was kind of lazy in both switching the screen on AND off.
I have been testing this for a few calls now and it seemed to work each time the phone failed to switch the screen on... Hope this can help!
NB: I'm running the "standard" 7.0.0-RC2

#29 gordy1

gordy1
  • Members
  • 1 posts
  • Device Model:
    ZTE Blade
  • CM Version:
    cm7
  • Recovery Image:
    Cyanogen

Posted 04 April 2011 - 05:19 PM

 Ogami Itto, on 17 March 2011 - 01:39 PM, said:

Hi.
I may have found a solution to this very annoying problem - well at least people who still face it should give this a try...
I think that earlier in this thread or in another one on this forum someone explained how to trigger the proximity sensor: I happened to test this, and it worked - notably when, after a call, my screen wouldn't switch on.
So when this happens try to put your forefinger horizontally on the top of the screen, as to hide the earpiece, and then remove it. Try a few times if it does not work instantly.
Looks like there's something wrong with this sensor, either hardware or software.
In the end I'm really not sure whether this is linked to the mod: I almost didn't use the original mod for my phone so I have no possible comparison, and it also seemed to me that the sensor was kind of lazy in both switching the screen on AND off.
I have been testing this for a few calls now and it seemed to work each time the phone failed to switch the screen on... Hope this can help!
NB: I'm running the "standard" 7.0.0-RC2

Hello

A newbie here.
I have the same loss of screen problem and I have tried the proximity fix but nothing happens.
I am not Android phone savvy so if someone could explain to me in laymans terms how to fix the bloody thing I would be most grateful

Edited by gordy1, 04 April 2011 - 05:19 PM.


#30 Ogami Itto

Ogami Itto
  • Donators
  • 33 posts
  • Country:
    fr - France
  • Device Model:
    ZTE Blade
  • CM Version:
    CM7 N72 modified
  • Recovery Image:
    ClockworkMod

Posted 05 April 2011 - 08:18 AM

 gordy1, on 04 April 2011 - 05:19 PM, said:

Hello

A newbie here.
I have the same loss of screen problem and I have tried the proximity fix but nothing happens.
I am not Android phone savvy so if someone could explain to me in laymans terms how to fix the bloody thing I would be most grateful

Hi gordy,
I've been running RC4 for a few days now and this issue is history on my phone.
I think I haven't experienced it since RC3, maybe N28 but I'm not so sure.
Did you try and update to RC4? Is the option "Force proximity sensor" on?
Now I have two distinct behaviours on my phone after a call:
- either the sensor worked correctly, and the screen lights up automatically
- or the sensor didn't work and the screen automatically went in standby mode (I have to switch it back on by pressing the power button)

So there's still something weird with the sensor, maybe the default value is not good, maybe it is badly located on the phone...
Or maybe I just don't hold the phone approprietly, but it's not very likely as my girlfriend's icrap's screen correctly goes out when I happen to use it! :D

#31 8200

8200
  • Members
  • 4 posts
  • Device Model:
    ZTE Blade
  • CM Version:
    Gen1 TFT
  • Recovery Image:
    ClockworkMod

Posted 05 April 2011 - 09:02 AM

Hi guys,

I am using CM 7.0 RC4 (update-cm-7.0.0-RC4-Blade-signed.zip) and also have this problem.

Changing the value of "ALWAYS USE PROXIMITY setting to YES" didn't solve it.


Also wifi tethering is working only for a few seconds.


Regards,
Arthur

#32 Ian Stacey

Ian Stacey
  • Members
  • 7 posts
  • Twitter:istacey
  • Country:
    uk - United Kingdom
  • Device Model:
    Nexus One, ZTE Blade
  • CM Version:
    CyanogenMod 7
  • Recovery Image:
    ClockworkMod

Posted 03 July 2011 - 05:28 PM

I'm experiencing this problem with the most recent nightly, 07032011. I'm assuming this nightly is later than the 7.1 RC and most certainly a later version that those above are talking about with their experiences of this issue.

Is this something that has been fixed and the bug crept back in or was it never fixed?

#33 Ronski

Ronski
  • Members
  • 2 posts
  • Device Model:
    ZTE Blade
  • CM Version:
    7.1
  • Recovery Image:
    Cyanogen

Posted 12 November 2011 - 05:43 PM

I'm having this problem on my wife's phone, whether she makes a call, or receives a call we cant wake the screen afterwards, have to either phone again, so there's a missed call, plug the charger in or take the battery out.

As you can imagine I'm getting grief from the wife.

Tried a few of the things above but no good, we're using 7.1 stable build.

Any idea's, this bug seems to have been around for some time now, has it been fixed?

#34 Ronski

Ronski
  • Members
  • 2 posts
  • Device Model:
    ZTE Blade
  • CM Version:
    7.1
  • Recovery Image:
    Cyanogen

Posted 13 November 2011 - 07:55 AM

Done some more Googling this morning, and found this issue report on Google code, which in turn led me to the ZTE Blade Settings found in applications, which has an option to calibrate the proximity sensor. I calibrated the sensor and it seems to have cured the problem. Anybody trying this you need to keep clear of the proximity sensor (near the ear piece) whilst it's running, there's no indication it's running so leave the phone for a while then wake it up and test.

#35 kaiser.ego

kaiser.ego
  • Members
  • 1 posts
  • Device Model:
    ZTE Blade
  • CM Version:
    253
  • Recovery Image:
    ClockworkMod

Posted 14 November 2011 - 04:04 PM

My Solution
use "Menu" ---> "ZTE Blade Settings" ---> "Proximity sensor calibration" and restart device.

#36 Humpel

Humpel
  • Members
  • 3 posts
  • Device Model:
    HTC Desire
  • CM Version:
    CyanogenMod-7.2.0-RC0-bravo-KANG
  • Recovery Image:
    Cyanogen

Posted 11 March 2012 - 03:22 PM

I had the same problem and just fixed it, it's so stupidly simple, that I'm actually annoyed about the time it took me to find it out :) I hope this one helps you frustrated guys out there:
I'm using the HTC Desire and it seems that they didn't seal the screen very well so dust can get inside. Just blow a few strong blows in the (almost invisible) gap on the upper side of the screen, where the proximity and light sensors are located. Alternatively use a vacuum cleaner which should also work.
Before my proximity sensor didn't report any other values than 0.0 (in the respective Apps), now it works just fine, turns off and on again without the need to press any buttons.
I hope this fix works for more phones than just the HTC Desire! Good luck :)

#37 rcdc69

rcdc69
  • Members
  • 1 posts
  • Country:
    uk - United Kingdom
  • Device Model:
    zte blade
  • CM Version:
    7.1
  • Recovery Image:
    ClockworkMod

Posted 22 June 2012 - 01:21 PM

use "Menu" ---> "ZTE Blade Settings" ---> "Proximity sensor calibration" and restart device.


That worked for me too

#38 pacaj2am

pacaj2am
  • Members
  • 2 posts
  • Device Model:
    TMobile G1
  • CM Version:
    pure
  • Recovery Image:
    Amon_RA

Posted 06 July 2012 - 03:46 PM

in 7.2 i can't find ZTE Settings. How should i do in 7.2? Thank you