Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse
 

Motorola Quench XT3 ?


  • Please log in to reply
123 replies to this topic

#21 Behemoth

Behemoth
  • Members
  • 18 posts
  • Country:
    in - India
  • Device Model:
    Motorola XT502
  • CM Version:
    CyanogenMod-7.1.0 Stable with CM7 EA Ubuntu#3 Kernel
  • Recovery Image:
    ClockworkMod

Posted 10 December 2010 - 01:51 PM

View PostKhumarahn, on 10 December 2010 - 12:04 AM, said:

Having just motorola logo in fastboot mode in normal behaviour. Actually, it would be strange to have anything else.

Use guide on fastboot from here: http://forum.xda-dev...ad.php?t=532719 (that guide is for different phone, but fastboot and commands are the same). If using windows, you can download fastboot binary and other programs for this phone if you search for A688 tools in google.

You can download Clockwork recovery, say, from here: http://boston-mania....01_archive.html, then flash it with fastboot.

You can find a lot of information on fastboot if you search xda-developers.

If you meet any diffuculties, we need to know EXACTLY what you did and EXACTLY what you observe to help.
Thanks Khumarahn, I was able to flash clockworkmod using fastboot. Again does anyone have the stock recovery image?

Edited by Behemoth, 10 December 2010 - 01:52 PM.


#22 benzyboy

benzyboy
  • Members
  • 14 posts
  • Country:
    id - Indonesia
  • Device Model:
    Motorola XT502
  • CM Version:
    6.1.2
  • Recovery Image:
    ClockworkMod

Posted 10 December 2010 - 02:28 PM

Here are some pics from the cell phone

Attached File  Auto FTM mode .jpg   19.6K   52 downloads
For this one I pressed volume up and down and power button, it starts with enter FTM mode, then cahnges to this screen
Attached File  enable diagport.jpg   24.83K   38 downloads
It's just stuck here
Attached File  Enable fastboot mode.jpg   25.73K   29 downloads
So is this one
Attached File  enable kernel uart log.jpg   21.41K   27 downloads
So is this one, what is this for btw?
Attached File  enter recovery mode.jpg   13.31K   32 downloads
This one just stuck here, wouldn't proceed to recovery mode
Attached File  I don't know but it said polling get oemsbl_mode.jpg   22.34K   36 downloads
This I don;t know
Attached File  Normal start up.jpg   27.12K   31 downloads
Normal start up, just stuck there without going anywhere

#23 Khumarahn

Khumarahn
  • Members
  • 47 posts
  • Country:
    ru - Russian Federation
  • Device Model:
    Motorola Quench XT3
  • CM Version:
    Cyanogen-Z71
  • Recovery Image:
    ClockworkMod

Posted 10 December 2010 - 03:57 PM

benzyboy, it is very unlikely that your phone is screwed. I wouldn't also bother about USB debugging option at this time.

I think, you need to

1. enter fastboot mode by shutting down your phone and pressing {HangUp key} + {Vol Down} + {Power} (while holding the other two), as Behemoth wrote. At this step you will only have motorola logo on the screen. IT IS FINE.

2. connect your phone to computer with microusb cable.

3. donwload fastboot from somewhere (google "a688 tools")

4. Learn what fastboot is (use detailed guide from http://forum.xda-dev...ad.php?t=532719 )

5. download recovery image (say, from here: http://boston-mania....01_archive.html )

6. check that fastboot can see your phone (run "fastboot devices", as far as I remember). Your phone should still display motorola logo.

7. flash that recovery image by executing fastboot like this: "fastboot flash recovery My_Recovery_Image.img".

8. run "fastboot reboot", or so, to reboot your phone

9. After that, try booting recovery, if it works, you can install cyanogen mod from zip files :-)

Please, let me know how it worked.

Edited by Khumarahn, 10 December 2010 - 04:00 PM.


#24 benzyboy

benzyboy
  • Members
  • 14 posts
  • Country:
    id - Indonesia
  • Device Model:
    Motorola XT502
  • CM Version:
    6.1.2
  • Recovery Image:
    ClockworkMod

Posted 10 December 2010 - 08:07 PM

I tried that and this is what i get on the comand prompt

Attached File  fastboot 1.JPG   41.87K   71 downloads
This is when i tried fastboot devices, the device is with question mark
Attached File  fastboot 2.JPG   61.39K   63 downloads
this is when i try to fastboot recovery image, it said error, actually this is the second time, the first time it says transferring files..., but since nothing happened i quit cmd and tried again, the second time this happened.

#25 Khumarahn

Khumarahn
  • Members
  • 47 posts
  • Country:
    ru - Russian Federation
  • Device Model:
    Motorola Quench XT3
  • CM Version:
    Cyanogen-Z71
  • Recovery Image:
    ClockworkMod

Posted 10 December 2010 - 08:25 PM

On your screenshots, "My_Recovery_Image.img" should a filename of file with recovery that you want to flash. You should download that file first, than use its filename there

#26 benzyboy

benzyboy
  • Members
  • 14 posts
  • Country:
    id - Indonesia
  • Device Model:
    Motorola XT502
  • CM Version:
    6.1.2
  • Recovery Image:
    ClockworkMod

Posted 11 December 2010 - 02:17 AM

Yes the filename is the same as the file, I downloaded recovery.img, first i renamed it as my_recovery_image.img, failed, then i renamed it again to recovery.img, failed also.

#27 benzyboy

benzyboy
  • Members
  • 14 posts
  • Country:
    id - Indonesia
  • Device Model:
    Motorola XT502
  • CM Version:
    6.1.2
  • Recovery Image:
    ClockworkMod

Posted 11 December 2010 - 02:26 AM

I tried it again and this happened
Attached File  fastboot 3.JPG   57.47K   53 downloads
it's just stuck there without anything happening

Edit
I tried it again and this happened
Attached File  fastboot 4.JPG   49.01K   49 downloads
So it managed to enter the phone and i rebooted, then it went to the motorola screen again, so i pulled out the battery and entered recovery mode. In recovery mode it said enter recovery mode with the M screen then changed to M screen only then stuck there, is there still something wrong?

Edited by benzyboy, 11 December 2010 - 02:41 AM.


#28 benzyboy

benzyboy
  • Members
  • 14 posts
  • Country:
    id - Indonesia
  • Device Model:
    Motorola XT502
  • CM Version:
    6.1.2
  • Recovery Image:
    ClockworkMod

Posted 11 December 2010 - 03:03 AM

Well I flashed my system images that i had backedup, then it worked back into 2.1 at least that's a relief, i'll try 2.2 later

Well I flashed my system images that i had backedup, then it worked back into 2.1 at least that's a relief, i'll try 2.2 later

Well I flashed my system images that i had backedup, then it worked back into 2.1 at least that's a relief, i'll try 2.2 later

#29 miteshpc

miteshpc
  • Members
  • 107 posts
  • Country:
    tz - Tanzania
  • Device Model:
    Motorola Quench XT3 XT502
  • CM Version:
    CM7 Final
  • Recovery Image:
    ClockworkMod

Posted 11 December 2010 - 08:51 PM

Does anybody has XT502 stock ROM, I seem to have corrupted mine without any backups. I am currently running CM6.1 but would be comfortable to keep the original stock ROM and flash it to get back the stock.

Not sure if it's possible to use somebody else's stock ROM and flash it on my phone though.

Thanks in advance.

BTW, my phone with CM6.1 (update-cm-6.1.0-Z71-signed.zip) keeps rebooting consistently every time I connect my USB port to my WinXP system. Doesn't give me that problem if I use a charger. Anybody faced similar issues?

Is it possible to share your backup with me privately?

View Postbenzyboy, on 11 December 2010 - 03:03 AM, said:

Well I flashed my system images that i had backedup, then it worked back into 2.1 at least that's a relief, i'll try 2.2 later

Well I flashed my system images that i had backedup, then it worked back into 2.1 at least that's a relief, i'll try 2.2 later

Well I flashed my system images that i had backedup, then it worked back into 2.1 at least that's a relief, i'll try 2.2 later


#30 Khumarahn

Khumarahn
  • Members
  • 47 posts
  • Country:
    ru - Russian Federation
  • Device Model:
    Motorola Quench XT3
  • CM Version:
    Cyanogen-Z71
  • Recovery Image:
    ClockworkMod

Posted 11 December 2010 - 08:57 PM

View Postbenzyboy, on 11 December 2010 - 03:03 AM, said:

Well I flashed my system images that i had backedup, then it worked back into 2.1 at least that's a relief, i'll try 2.2 later


Great, this means your phone is not bricked, congratulations :-)

#31 srtengse

srtengse
  • Members
  • 6 posts
  • Country:
    in - India
  • Device Model:
    Motorola XT3
  • CM Version:
    cm-6.1.2-Z71, but back to stock
  • Recovery Image:
    ClockworkMod

Posted 14 December 2010 - 05:53 AM

I am in the same situation as 'benzyboy'
I am running cm-6.1.0-Z71 on my Motorola XT3 for the last 4 days, never had a problem except that the battery used to drain in 24hrs with minimal usage. Wanted to re-calibrate battery monitor, so allowed the battery to drain out today morning and after charging back, voila, the phone refuses to boot  :angry: . It stays with the initial Motorola logo.

I doesn't even enter recovery, again gets stuck with the Motorola logo..
I guess I have to go back and try the fastboot with a recovery image, but got stuck in office, will go home today evening and report back...

Any work arounds other than flashing via fastboot ??

#32 benzyboy

benzyboy
  • Members
  • 14 posts
  • Country:
    id - Indonesia
  • Device Model:
    Motorola XT502
  • CM Version:
    6.1.2
  • Recovery Image:
    ClockworkMod

Posted 14 December 2010 - 10:28 AM

Hello there
That happen to me, my phone's battery dried out then i charged it to full and it won't boot and stuck at the motorola icon. What I did is flashed the recovery-clockwork-2.5.1.1-z71.img through fastboot, and the update.zip (which contains the cm-6.1) then i entered recovery mode, then just install from update.zip. Then my phone worked again to normal, and my data is still there, contacts sms and apps.
So is the XT3 have a bad battery usage? because i hardly can use it for more than 4 hours from 100 percent on the internet, is there a way to optimize the battery?

View Postsrtengse, on 14 December 2010 - 05:53 AM, said:

I am in the same situation as 'benzyboy'
I am running cm-6.1.0-Z71 on my Motorola XT3 for the last 4 days, never had a problem except that the battery used to drain in 24hrs with minimal usage. Wanted to re-calibrate battery monitor, so allowed the battery to drain out today morning and after charging back, voila, the phone refuses to boot  :angry: . It stays with the initial Motorola logo.

I doesn't even enter recovery, again gets stuck with the Motorola logo..
I guess I have to go back and try the fastboot with a recovery image, but got stuck in office, will go home today evening and report back...

Any work arounds other than flashing via fastboot ??


#33 srtengse

srtengse
  • Members
  • 6 posts
  • Country:
    in - India
  • Device Model:
    Motorola XT3
  • CM Version:
    cm-6.1.2-Z71, but back to stock
  • Recovery Image:
    ClockworkMod

Posted 14 December 2010 - 04:00 PM

Phew.... something worked at last  B)

Today has been an adventure and it looked as if I was proving Murphy’s theorem “If anything can go wrong, it will !!”

Today morning I get up and saw the battery is close to 10%, as I was struggling with CM.6.1.0 for battery performance, I thought let me drain out the battery in order to recalibrate the battery monitor. So let it drain completely.

I charged the battery and then switch on the phone and.... nothing happens, all I see is a big white ‘M’, no key works, I remove the battery and try again.... still nothing but the big beautiful Motorola logo. :blink:

I said well I know something , so let me use magic keys ‘Camera+Vol Up+Power’.  Now I get a small text ‘Enter Recovery Mode’ and that stupid logo again.. Grrr  :angry:

I look up the Forums, and found my dear friend ‘benzyboy’ had the same issue and try to follow a very well compiled guide from ‘Khumarahn

So the first step said ‘Install ADB/SDK/Fastboot’, I said ok that is easy, let me do it.. I did install and download the drivers too..

Step 2 : Enter into fastboot mode (HangUp+VolDown+Power) and connect to PC and check the devices.. Okay I say, fastboot ok, connect to PC (Win XP + SP3) and then I am prompted for drivers.. latest drivers from Google don’t get installed... Fastboot doesn’t recognize my Phone... My heart skips a beat...Did I brick my phone ?? :o

Now I read this article completely as suggested by  ‘Khumarahn’ : Guide for ADB/Fastboot
I install USBDeview, remove all ‘Motorola’, ‘Google’ and ‘Z71’ devices related to removable drives/modems/Phone.

I download the drivers again from : USB Drivers
Connect back the Phone in Fastboot. Now I am prompted again for the drivers and this time the downloaded drivers work !! A glimmer of hope, something is working  :unsure:
Now quickly fastboot devices .... What do I get ?? I get a “?”.. I don’t lose hope,  I see that  ‘benzyboy’ had the same symptoms.. so flash the clockwork recovery ‘recovery-clockwork-2.5.1.3-z71.img
I get a message :
>fastboot flash recovery recovery-clockwork-2.5.1.3-z71.img
  sending 'recovery' (3742 KB)... OKAY [  0.938s]
 writing 'recovery'... OKAY [  0.781s]
finished. total time: 1.719s
I quickly say ‘fastboot reboot’... fingers crossed.... Ugghhh not that ugly logo again, I am no longer a fan of that logo...
I try to follow ‘benzyboy’ and try to flash the update.zip.
>fastboot update update-cm-6.1.0-Z71-signed.zip
archive does not contain 'android-info.txt'
archive does not contain 'android-product.txt'
error: update package has no android-info.txt or android-product.txt

Now what.... Some more frantic googling, and I come across some instances where a corrupt cache and dalvik-cache led to hung systems...

I take a plunge, I had saved my Nandroid backup on the computer. So I flash the boot, cache and data partitions from the backed up stock ROM using flashboot...
I reboot, what do I see ??? Mr.M again  :(

I was about to throw the phone and goto bed.... suddenly it boots into ‘Clockwork’ recovery !!! How did that happen ?? No idea, but I am not complaining  :D

I now erase cache and user data and then I restore the stock ROM and now I have my phone back...  B)
So lived to fight another day and tomorrow I am trying CM-6.1.1, lets see if this one solves my battery issues...

Edited by srtengse, 14 December 2010 - 04:01 PM.


#34 srtengse

srtengse
  • Members
  • 6 posts
  • Country:
    in - India
  • Device Model:
    Motorola XT3
  • CM Version:
    cm-6.1.2-Z71, but back to stock
  • Recovery Image:
    ClockworkMod

Posted 14 December 2010 - 04:07 PM

I rambled so much in my last post, so summary of things I did :

1. Installed Android SDK from http://developer.and...index.html  and updated my USB drivers.(had problems with the USB drivers, but this guide saved my day : http://forum.xda-dev...ad.php?t=532719 )
2. Flashed ‘recovery-clockwork-2.5.1.3-z71.img’ via fastboot. Still cannot boot, cannot get into recovery.
3. Flashed my backed up partitions ‘boot’ ‘cache’ and ‘data’
4. Finally could boot into clockwork recovery.
5. Wiped user data & cache. Restored backed up stock ROM. Now good to go.. back to Eclair.. but I can use my phone.

#35 Khumarahn

Khumarahn
  • Members
  • 47 posts
  • Country:
    ru - Russian Federation
  • Device Model:
    Motorola Quench XT3
  • CM Version:
    Cyanogen-Z71
  • Recovery Image:
    ClockworkMod

Posted 14 December 2010 - 07:04 PM

View Postsrtengse, on 14 December 2010 - 05:53 AM, said:

Wanted to re-calibrate battery monitor, so allowed the battery to drain out today morning and after charging back, voila, the phone refuses to boot  :angry: . It stays with the initial Motorola logo.

I doesn't even enter recovery, again gets stuck with the Motorola logo..

I had an issue like that once. The battery drained out and the phone didn't boot. I was running some nightly cyanogen. And I didn't know what to do, so I left the phone charging for some time (quite long, 30 minutes or may be more), and it booted nicely after that. I didn't do any partition flashing.

BTW, I never have motorola logo at boot any more. I replaced it with my own picture which I like :-))

#36 benzyboy

benzyboy
  • Members
  • 14 posts
  • Country:
    id - Indonesia
  • Device Model:
    Motorola XT502
  • CM Version:
    6.1.2
  • Recovery Image:
    ClockworkMod

Posted 15 December 2010 - 12:15 AM

Oh god I'm sorry

I gave you one wrong instruction, i meant not flash the 6.i update.zip through fastboot, but through recovery mode. Sorry about the mistake, good thing you manage to get it working again though

#37 neptunex3

neptunex3
  • Members
  • 23 posts
  • Country:
    in - India
  • Location:
    Bangalore, India
  • Device Model:
    Motorola quench xt3
  • CM Version:
    SuperBler v4
  • Recovery Image:
    ClockworkMod

Posted 15 December 2010 - 05:54 AM

Hi Khumarahn,

i just bought Motorola quench xt3....it came with Android 2.1 'update 1'....ok now i would like to upgrade to 2.2...i need your help

i am verymuch new to Android platform, i don't know anything....Can you please make some step by step guide with all basic information needed....i hope i am not disturbing you.

with my little knowledge i could manage to root my device with 'Z4root'....so now my device rooted. i don't know what to do next.

i am using Windows XP with service pack3 and dotnet frame work installed.

also i would like to know can we install custom rom(for 2.1)......where can we get...also how i can identify whether it will work with xt3 or not...is there any specific forum for XT3.?

i hope you will help me in this...sorry if i am disturbing you..

Thanks in advance

Cheers

#38 Khumarahn

Khumarahn
  • Members
  • 47 posts
  • Country:
    ru - Russian Federation
  • Device Model:
    Motorola Quench XT3
  • CM Version:
    Cyanogen-Z71
  • Recovery Image:
    ClockworkMod

Posted 15 December 2010 - 05:53 PM

Hi neptunex3

My experience is very limited - I only know what worked for my phone that came with android 1.6. I wrote what I did on the first page in this topic.

From what I have seen and read, the following may work for your already rooted phone:

1. Install Rom Manager using Google Market
2. Use Rom Manager to flash latest Clockwork recovery (choose Z71 as phone model)
3. Use Rom Manager to download and install latest stable Cyanogen mod

You don't need to use big computer at all. However, if 2nd step fails, I'd try flashing recovery using fastboot, and then you'd need computer. But first I'd try what I just described above.

Edited by Khumarahn, 16 December 2010 - 04:50 AM.


#39 neptunex3

neptunex3
  • Members
  • 23 posts
  • Country:
    in - India
  • Location:
    Bangalore, India
  • Device Model:
    Motorola quench xt3
  • CM Version:
    SuperBler v4
  • Recovery Image:
    ClockworkMod

Posted 16 December 2010 - 05:02 AM

Thanks Khumarahn,

i will try and let you know....

is it possible to install apps in SD card (for 2.1)?...

Thank you very much.

cheers

#40 Khumarahn

Khumarahn
  • Members
  • 47 posts
  • Country:
    ru - Russian Federation
  • Device Model:
    Motorola Quench XT3
  • CM Version:
    Cyanogen-Z71
  • Recovery Image:
    ClockworkMod

Posted 16 December 2010 - 03:20 PM

View Postneptunex3, on 16 December 2010 - 05:02 AM, said:

is it possible to install apps in SD card (for 2.1)?...

I don't know, I never used 2.1. But for cyanogen >=6.1.0 it is easy and straightforward.